문제
숫자 카드는 정수 하나가 적혀져 있는 카드이다. 상근이는 숫자 카드 N개를 가지고 있다. 정수 M개가 주어졌을 때, 이 수가 적혀있는 숫자 카드를 상근이가 몇 개 가지고 있는지 구하는 프로그램을 작성하시오.
입력
첫째 줄에 상근이가 가지고 있는 숫자 카드의 개수 N(1 ≤ N ≤ 500,000)이 주어진다. 둘째 줄에는 숫자 카드에 적혀있는 정수가 주어진다. 숫자 카드에 적혀있는 수는 -10,000,000보다 크거나 같고, 10,000,000보다 작거나 같다. 셋째 줄에는 M(1 ≤ M ≤ 500,000)이 주어진다. 넷째 줄에는 상근이가 몇 개 가지고 있는 숫자 카드인지 구해야 할 M개의 정수가 주어지며, 이 수는 공백으로 구분되어져 있다. 이 수도 -10,000,000보다 크거나 같고, 10,000,000보다 작거나 같다.
출력
첫째 줄에 입력으로 주어진 M개의 수에 대해서, 각 수가 적힌 숫자 카드를 상근이가 몇 개 가지고 있는지를 공백으로 구분해 출력한다.
예제 입력
10
6 3 2 10 10 10 -10 -10 7 3
8
10 9 -5 2 3 4 5 -10
예제 출력
3 0 0 1 2 0 0 2
풀이
- lower_bound(arr, arr+N, value) : value값보다 크거나 같은 첫 번째 원소의 주소를 리턴한다.
- upper_bound(arr, arr+N, value) : value값을 처음으로 초과하는 원소의 주소를 리턴한다.
※ 자세한 설명 - > [https://cocoon1787.tistory.com/324]
Solution
C++
#include <iostream>
#include <algorithm> //sort(), binary_search() 쓰기 위해 필요
using namespace std;
#define MAX 500000
int N, n[MAX], M, m[MAX], result[MAX] = {0,};
int main() {
cin >> N;
for(int i = 0; i < N; i++)
cin >> n[i];
sort(n, n+N); //이분 탐색을 하기 위해서는 정렬이 필요
cin >> M;
for(int i = 0; i < M; i++)
cin >> m[i];
for(int i = 0; i < M; i++){
if(binary_search(n, n+N, m[i])){ //이분 탐색을 통해서 값을 찾는다.
int high = upper_bound(n, n + N, m[i]) - n; //중복 개수를 찾음
int low = lower_bound(n, n+N, m[i]) - n;
result[i] = high - low;
}
}
for(int i = 0; i < M; i++)
cout << result[i] << ' ';
return 0;
}
Python (sol1)
#128388KB / 2856ms
from sys import stdin
N = stdin.readline()
NCard = sorted(map(int, stdin.readline().split()))
M = stdin.readline()
MCard = map(int, stdin.readline().split())
def Binary_Search(x, NCard, start, end):
if start > end:
return 0
mid = (start + end) // 2
if NCard[mid] == x:
return cnt.get(x) #dict.get(key, default = None)
elif NCard[mid] > x:
return Binary_Search(x, NCard, start, mid - 1)
else:
return Binary_Search(x, NCard, mid + 1, end)
cnt = { } #dictionary
for i in NCard:
if i in cnt:
cnt[i] += 1
else:
cnt[i] = 1
for i in MCard:
print(Binary_Search(i, NCard, 0, len(NCard)-1), end = ' ')
Python (sol2)
#126568KB / 964ms
from sys import stdin
from collections import Counter #collections - 컨테이너 데이터형
M = stdin.readline()
MCard = sorted(map(int, stdin.readline().split()))
N = stdin.readline()
NCard = map(int, stdin.readline().split())
C = Counter(MCard) #Counter({10: 3, -10: 2, 3: 2, 2: 1, 6: 1, 7: 1})
#print(C) #Dictionary 자료형 출력
#print(' '.join(f'{C[m]}' if m in C else '0' for m in NCard))
#위의 print문 풀어쓰면 아래 for문 처럼 하면 됨.
for m in NCard: #Counter(MCard)에 NCard의 요소가 있다면 해당 숫자를 출력하고 없으면 0을 출력
if m in C:
print(C[m], end= " ")
else:
print(0, end= " ")
'BOJ 코딩테스트 > Silver' 카테고리의 다른 글
BOJ 11726번 : 2×n 타일링 (C++/Silver 3) (0) | 2022.09.26 |
---|---|
BOJ 9095번 : 1, 2, 3 더하기 (C++/Silver 3) (0) | 2022.09.23 |
BOJ 1654번 : 랜선 자르기 (C++/Silver 2) (0) | 2022.09.18 |
BOJ 10815번 : 숫자 카드 (C++/Silver 5) (0) | 2022.09.16 |
BOJ 1094번 : 막대기 (C++/Silver 5) (0) | 2022.09.05 |