문제
영문 문장을 입력받아 모음의 개수를 세는 프로그램을 작성하시오. 모음은 'a', 'e', 'i', 'o', 'u'이며 대문자 또는 소문자이다.
입력
입력은 여러 개의 테스트 케이스로 이루어져 있으며, 각 줄마다 영어 대소문자, ',', '.', '!', '?', 공백으로 이루어진 문장이 주어진다. 각 줄은 최대 255글자로 이루어져 있다. 입력의 끝에는 한 줄에 '#' 한 글자만이 주어진다.
출력
각 줄마다 모음의 개수를 세서 출력한다.
예제 입력
How are you today?
Quite well, thank you, how about yourself?
I live at number twenty four.
#
예제 출력
7
14
9
Solution
C++
#include <iostream>
#include <string>
using namespace std;
int main() {
string s;
while(1){
int cnt = 0;
getline(cin, s);
for(int i=0; i<s.length(); i++){
s[i] = tolower(s[i]); //전체 소문자로 변환
if(s[i] == 'a' || s[i] == 'e' || s[i] == 'i' || s[i] == 'o' || s[i] == 'u')
cnt++;
}
if(s == "#") break;
cout << cnt << '\n';
}
return 0;
}
Python
while 1:
n = input()
if n == '#': break;
cnt = 0
n = n.lower()
for char in n:
if char in ('a', 'e', 'i', 'o', 'u'):
cnt = cnt + 1
print(cnt)
'BOJ 코딩테스트 > Bronze' 카테고리의 다른 글
BOJ 1157번 : 단어 공부 (C++/Bronze 1) (0) | 2022.08.30 |
---|---|
BOJ 1152번 : 단어의 개수 (C++/Bronze 2) (0) | 2022.08.30 |
BOJ 10808번 : 알파벳 개수 (Python/Bronze 4) (0) | 2022.08.21 |
BOJ 2440번 : 별 찍기 - 3 (C++/Bronze 4) (0) | 2022.08.21 |
BOJ 2338번 : 긴자리 계산 (Python/Bronze 5) (0) | 2022.08.18 |