Stay Hungry Stay Foolish

BOJ 코딩테스트/Silver

BOJ 10816번 : 숫자 카드2 (Python/Silver 4)

dev스카이 2023. 3. 20. 22:34
 

10816번: 숫자 카드 2

첫째 줄에 상근이가 가지고 있는 숫자 카드의 개수 N(1 ≤ N ≤ 500,000)이 주어진다. 둘째 줄에는 숫자 카드에 적혀있는 정수가 주어진다. 숫자 카드에 적혀있는 수는 -10,000,000보다 크거나 같고, 10,

www.acmicpc.net

문제

숫자 카드는 정수 하나가 적혀져 있는 카드이다. 상근이는 숫자 카드 N개를 가지고 있다. 정수 M개가 주어졌을 때, 이 수가 적혀있는 숫자 카드를 상근이가 몇 개 가지고 있는지 구하는 프로그램을 작성하시오.

 

입력

첫째 줄에 상근이가 가지고 있는 숫자 카드의 개수 N(1 ≤ N ≤ 500,000)이 주어진다. 둘째 줄에는 숫자 카드에 적혀있는 정수가 주어진다. 숫자 카드에 적혀있는 수는 -10,000,000보다 크거나 같고, 10,000,000보다 작거나 같다.

셋째 줄에는 M(1 ≤ M ≤ 500,000)이 주어진다. 넷째 줄에는 상근이가 몇 개 가지고 있는 숫자 카드인지 구해야 할 M개의 정수가 주어지며, 이 수는 공백으로 구분되어져 있다. 이 수도 -10,000,000보다 크거나 같고, 10,000,000보다 작거나 같다.

 

출력

첫째 줄에 입력으로 주어진 M개의 수에 대해서, 각 수가 적힌 숫자 카드를 상근이가 몇 개 가지고 있는지를 공백으로 구분해 출력한다.


예제 입력

10
6 3 2 10 10 10 -10 -10 7 3
8
10 9 -5 2 3 4 5 -10

예제 출력

3 0 0 1 2 0 0 2

풀이

- 이분탐색 이용

Solution

시간초과 풀이

M = int(input())
MCard = list(map(int, input().split()))
N = int(input())
NCard = list(map(int, input().split()))

MCard.sort() #sort O(nlogn)
r = []
def Binary_Search(x):
    start = 0
    end = M - 1
    num = 0
    while start <= end:
        mid = (start + end) // 2
        if MCard[mid] == x:
            #num += 1
            #MCard.remove(x)
            return MCard.count(x) #count O(n^2)

        if MCard[mid] < x:
            start = mid + 1
        else:
            end = mid - 1
    return 0

for i in NCard:
    r.append(Binary_Search(i))
print(r)

 

옳은 풀이 1 (Counter 이용)

from sys import stdin
from collections import Counter #collections - 컨테이너 데이터형

M = stdin.readline()
MCard = sorted(map(int, stdin.readline().split()))
N = stdin.readline()
NCard = map(int, stdin.readline().split())

C = Counter(MCard) #Counter({10: 3, -10: 2, 3: 2, 2: 1, 6: 1, 7: 1})
print(' '.join(f'{C[m]}' if m in C else '0' for m in NCard))

옳은 풀이 2 (Dict 이용)

from sys import stdin
N = stdin.readline()
NCard = sorted(map(int, stdin.readline().split()))
M = stdin.readline()
MCard = map(int, stdin.readline().split())

def Binary_Search(x, NCard, start, end):
    if start > end:
        return 0
    mid = (start + end) // 2
    if NCard[mid] == x:
        return cnt.get(x) #dict.get(key, default = None)
    elif NCard[mid] > x:
        return Binary_Search(x, NCard, start, mid - 1)
    else:
        return Binary_Search(x, NCard, mid + 1, end)

cnt = { } #dictionary
for i in NCard:
    if i in cnt:
        cnt[i] += 1
    else:
        cnt[i] = 1

for i in MCard:
    print(Binary_Search(i, NCard, 0, len(NCard)-1), end = ' ')